Magic-League.com Forum Index Magic-League.com
Forums of Magic-League: Free Online tcg playing; casual or tournament play.
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Mws on Mac


Goto page Previous  1, 2, 3, 4  Next
 
Reply to topic    Magic-League.com Forum Index -> Magic Workstation (MWS)
Author Message
MioCid



Joined: 04 Oct 2004
Posts: 12

PostPosted: Tue Sep 23, 2008 9:12 am    Post subject: Reply with quote

My version of Ubuntu is 8.04
My version of Wine is 1.0

I have a 1.6 GHz intel centrino processor with 512 MB ram, and my graphic card is some model of nVidia, with all the drivers in use.
Back to top
MioCid



Joined: 04 Oct 2004
Posts: 12

PostPosted: Tue Sep 23, 2008 12:31 pm    Post subject: Reply with quote

Installed Wine 1.1.5. Now I can see the cards in MWSPlay, but cannot see life totals, mana pool or cards in library yet.

Any idea?
Back to top
MioCid



Joined: 04 Oct 2004
Posts: 12

PostPosted: Wed Sep 24, 2008 10:03 am    Post subject: Reply with quote

Here you have it

http://www.megaupload.com/?d=XRGY1JNH

I cannot see p/t nor the names of the cards, cards remaining in library or in hand... well, u can see the screen. At this moment, I think it's playable, but fixing this issues would be great.

By the way, which irc client do you use in Linux?

Ah, and also, many thanks to Azania for your help Smile
Back to top
Smegma



Joined: 11 Jul 2007
Posts: 5

PostPosted: Wed Sep 24, 2008 11:36 am    Post subject: Reply with quote

There are a bit of ways to solve this problem.

Code:
sudo apt-get install ubuntu-restricted-extras


However, this installs unnecessary things to just run MWS. I believe defoma will solve this problem.

Code:
sudo apt-get install defoma


Should solve it. Its a font manager, which seems to be your only trouble. I had the restricted-extras installed already, before having installed workstation.
Back to top
MioCid



Joined: 04 Oct 2004
Posts: 12

PostPosted: Wed Sep 24, 2008 12:51 pm    Post subject: Reply with quote

Tried that, installed both things you said, but MWSplay looks the same Sad

any advice about the irc client i should use?
Back to top
Smegma



Joined: 11 Jul 2007
Posts: 5

PostPosted: Wed Sep 24, 2008 3:02 pm    Post subject: Reply with quote

Do you have the log from when you installed it?


Also, I just use xchat on this computer. I dont really need anything too particular from my client though.
Back to top
goat314



Joined: 11 Feb 2006
Posts: 17

PostPosted: Thu Sep 25, 2008 9:10 am    Post subject: Reply with quote

I wonder if this is the mac problem, too... I'll be able to check on Saturday, if nobody else can before that.
Back to top
MioCid



Joined: 04 Oct 2004
Posts: 12

PostPosted: Thu Sep 25, 2008 10:17 am    Post subject: Reply with quote

I do have those files in the /usr/share/wine/fonts/ but i have no directory named home/*user*/.wine/drive_c/windows/Fonts/ dir (and yes, I changed *user* with my name) this is the tree of wine-1.1.5

aclocal.m4 configure documentation libs Makefile.in server
ANNOUNCE configure.ac fonts LICENSE Make.rules.in tools
AUTHORS COPYING.LIB hardy.sh LICENSE.OLD programs VERSION
config.log dlls include loader README

no folder named "drive_c"

I don't have those
georgia.ttf georgiab.ttf pala.ttf palab.ttf

Again, many thanks for ur help
Back to top
MioCid



Joined: 04 Oct 2004
Posts: 12

PostPosted: Thu Sep 25, 2008 1:01 pm    Post subject: Reply with quote

Sorry, Indeed I had those two directories. I copied the first batch of files into the 2nd folder, but I dunno why it didn't let me do the same with the 2nd batch (the ttf files) into the 1st folder.

MWS is in

/.wine/drive_c/Archivos de programa/Magic Workstation
Back to top
Smegma



Joined: 11 Jul 2007
Posts: 5

PostPosted: Thu Sep 25, 2008 4:05 pm    Post subject: Reply with quote

Azania wrote:
Smegma wrote:
Do you have the log from when you installed it?


Also, I just use xchat on this computer. I dont really need anything too particular from my client though.


Could you please verify MWS works on your linux box and which distro you are running if you do not have ubunto installed?

(yes i know triple post but could not bother to cp it all in 1 post)


I'm running it on Ubuntu 8.04

Back to top
Smegma



Joined: 11 Jul 2007
Posts: 5

PostPosted: Thu Sep 25, 2008 5:48 pm    Post subject: Reply with quote

No just the latest version of wine, and installing ubuntu-restricted-extras seemed to make it work just fine.
Back to top
Smegma



Joined: 11 Jul 2007
Posts: 5

PostPosted: Fri Sep 26, 2008 2:29 pm    Post subject: Reply with quote

In /user/.wine/drive_c/windows/Fonts

I have georgia.ttf, georgiab.ttf, pala.ttf, palab.ttf
Back to top
goat314



Joined: 11 Feb 2006
Posts: 17

PostPosted: Fri Sep 26, 2008 6:20 pm    Post subject: Reply with quote

For my fiance's mac:

I also, had the same 4 files. I tried copying all the fonts from my winxp laptop to the drive_c/windows/Fonts folder. This did not work, no life, card counts, card titles, or P/T.
Back to top
MioCid



Joined: 04 Oct 2004
Posts: 12

PostPosted: Mon Sep 29, 2008 9:09 am    Post subject: Reply with quote

I have all the fonts u said, in the folders they should be.

can i get more info about the "ubuntu-restricted-extras"?
Back to top
MioCid



Joined: 04 Oct 2004
Posts: 12

PostPosted: Tue Sep 30, 2008 10:25 am    Post subject: Reply with quote

Perfect

Now it works flawlessly

many many thanks to you, Azania.
Back to top
Display posts from previous:   
Reply to topic    Magic-League.com Forum Index -> Magic Workstation (MWS) All times are GMT - 7 Hours
Goto page Previous  1, 2, 3, 4  Next
Page 2 of 4

 


Powered by phpBB © 2001, 2005 phpBB Group

All content on this page may not be reproduced without consent of Magic-League Directors.
Magic the Gathering is TM and copyright Wizards of the Coast, Inc, a subsidiary of Hasbro, Inc. All rights reserved.


About Us | Contact Us | Privacy Policy